malloc with DARWIN executable and ExodusII input mesh

malloc with DARWIN executable and ExodusII input mesh

Postby regueiro » Wed Jan 04, 2012 3:46 pm


I finally successfully built ACCESS on my Mac OS 10.6.8, Intel Core 2 Duo.

I used the DARWIN fink macro to build Tahoe, using gcc 4.4.4: ... ink.macros

Tahoe successfully builds, and I am able to run sims consistently using Tahoe input, with ExodusII output, such as in


but when I use .g ExodusII input meshes, I occasionally get Tahoe to run, but more often than not get this error when running a file in this dir


[ceae-228-81-dhcp:solid_fluid_mix/soft_tissue/column_compress] regueiro% tahoe_d -f column10cm_traction_consol.xml

Tahoe 2.1

Copyright 2003, Sandia Corporation.
All rights reserved.

Under the terms of Contract DE-AC04-94AL85000, there is a non-exclusive
license for use of this work by or on behalf of the U.S. Government. Export
of this program may require a license from the United States Government.

build: 14:10:48, Jan 4 2012

Extended error checking is OFF
Turn on "extended error checking" to add.

RunJob_analysis, serial version: column10cm_traction_consol.xml
tahoe_d(13981) malloc: *** error for object 0x100b00730: incorrect checksum for freed object - object was probably modified after being freed.
*** set a breakpoint in malloc_error_break to debug
[ceae-228-81-dhcp:solid_fluid_mix/soft_tissue/column_compress] regueiro% pwd
[ceae-228-81-dhcp:solid_fluid_mix/soft_tissue/column_compress] regueiro%

Any ideas why I am getting this error?



Re: malloc with DARWIN executable and ExodusII input mesh

Postby Guest » Mon Jan 09, 2012 9:00 am


We encountered a variant of this problem building on 10.6 using GCC 4.2. It only happened when my students used CUBIT to create exodus rather than genesis file formats. We spent many frustrating months debugging this before realization why files I created ran (genesis) fine but files they created (exodus) encountered malloc errors. It sounds like you are getting the opposite problem.

Re: malloc with DARWIN executable and ExodusII input mesh

Postby regueiro » Tue Jan 17, 2012 2:36 pm

Hello ?,

Well, that worked! I loaded the .cub file in Cubit 13.1 on my Mac laptop, and then exported as Genesis, turning off the Large File Format. I then ran Tahoe again on my Mac for various xml files in the dir indicated above, and it worked just fine.



Return to Tahoe Development Server

Who is online

Users browsing this forum: No registered users and 1 guest